客户中心 > 帮助中心 > 帮助文档 > Linux系统 > Linux下使用混淆ssh代理的参考教程


Linux下使用混淆ssh代理的参考教程




GFW对标准ssh协议的干扰越来越猛烈了,我们强烈建议用户使用混淆ssh协议连接我们的ssh代理服务器。

要在Linux系统使用混淆ssh代理,需要重新编译支持混淆ssh协议的openssh软件,下面以ubuntu系统为例给各位用户做个参考:

1.打开终端,下载支持混淆ssh协议的openssh源码

wget  http://www.123ssh.com/obfuscated-openssh.zip

2.准备工作

unzip obfuscated-openssh.zip

chmod -Rc 755 obfuscated-openssh

cd obfuscated-openssh

apt-get install -y make

3.编译安装:

./configure --prefix=/usr --sysconfdir=/etc/ssh
 
make
 
make install
 
安装完成,使用混淆ssh协议连接
 
ssh -Nfx -D 7070  username@server -p 443 -Z usassh
 
参数解释
-Z usassh :使用混淆加密密钥usassh
-p 443:使用端口443,因为我们的混淆加密ssh开了443和2222端口
username 替换为 您的一号通账号
server  替换为 一号通服务器地址
 


此答案有用么?

添加到收藏 添加到收藏    打印 打印

建议阅读

Language: